unable to mount XFS after rescue

I am facing strange problem with XFS file system. Below is the exact scenario:

I’d a corrupt 2 TB disk with XFS (I/O error), so that decide to rescue data from old disk to new disk.

I’d run ddrescue to rescue data to new disk. ddrescue finished successfully except 204 kB data. After that I was trying to mount the new disk but no luck. Below I am posting the ddrescue result and mount error. Please help me to solve the issue. I’ll be really grateful.

ddrescue result:

# ddrescue --force -n /dev/sdc /dev/sde
GNU ddrescue 1.16
About to copy 2198 GB from /dev/sdc to /dev/sde
Starting positions:
Infile = 0 B, outfile = 0 B
Copy Block size: 128 sectors Initial skip size: 128 sectors Sectors size: 512 Bytes

Press Ctrl-C to interrupt
rescued : 2198 GB, errsize : 204 kB, current rate : 1560 B/s
Ipos : 68699 MB, errors : 15, average rate : 29103 KB/s
Opos : 68699 MB, time since last successful read : 0 s
Finished

# fdisk -l
Disk /dev/sdc: 2198.3 GB, 2198352166912 bytes 255 heads, 63 sectors/track, 267267 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/sdc1 1 267350 2147483647+ ee EFI GPT

Disk /dev/sde: 2198.3 GB, 2198352166912 bytes 255 heads, 63 sectors/track, 267267 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sde1 1 267350 2147483647+ ee EFI GPT

# ls -l /dev/sd*
brw-r—– 1 root disk 8, 0 Feb 28 02:00 /dev/sda
brw-r—– 1 root disk 8, 1 Feb 28 02:00 /dev/sda1
brw-r—– 1 root disk 8, 2 Feb 28 02:00 /dev/sda2
brw-r—– 1 root disk 8, 3 Feb 27 18:00 /dev/sda3
brw-r—– 1 root disk 8, 4 Feb 28 02:00 /dev/sda4
brw-r—– 1 root disk 8, 5 Feb 28 02:00 /dev/sda5
brw-r—– 1 root disk 8, 16 Feb 28 02:00 /dev/sdb
brw-r—– 1 root disk 8, 17 Feb 28 02:00 /dev/sdb1
brw-r—– 1 root disk 8, 32 Feb 28 02:00 /dev/sdc
brw-r—– 1 root disk 8, 48 Feb 28 02:00 /dev/sdd
brw-r—– 1 root disk 8, 49 Feb 28 02:00 /dev/sdd1
brw-r—– 1 root disk 8, 64 Feb 28 02:00 /dev/sde

Inside # fdisk -l command /dev/dec1 and /dev/sde1 missing

# parted -i /dev/sde print
Model: DELL PERC 5/i (scsi)
Disk /dev/sde: 2198GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 2198GB 2198GB primary xfs

Information: Don’t forget to update /etc/fstab, if necessary.

# mount -t xfs /dev/sde /mnt/mail3
mount: wrong fs type, bad option, bad superblock on /dev/sde,
missing codepage or other error
In some cases useful info is found in syslog – try
dmesg | tail or so

# dmesg | tail
XFS: bad magic number
XFS: SB validate failed

# tailf /var/log/messages
Feb 28 04:09:29 mail kernel: XFS: bad magic number
Feb 28 04:09:29 mail kernel: XFS: SB validate failed

# file -s /dev/sde
/dev/sde: x86 boot sector; partition 1: ID=0xee, starthead 0, startsector 1, 4294967295 sectors, extended partition table (last)\011

# xfs_check /dev/sde1
/dev/sde1: No such file or directory

fatal error — couldn’t initialize XFS library

# xfs_check /dev/sde
xfs_check: unexpected XFS SB magic number 0x00000000
xfs_check: read failed: Invalid argument
xfs_check: data size check failed
cache_node_purge: refcount was 1, not zero (node=0xdc92c20)
xfs_check: cannot read root inode (22)
bad superblock magic number 0, giving up

Please help and it will be highly appreciated.

Answer

Attribution
Source : Link , Question Author : rh.mahfuz , Answer Author : Community

Leave a Comment