openvz / centos 6 vps yum failing with error

Installed new openvz container with centos 6.4 64bit

Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-431.el6 will be installed
--> Processing Dependency: kernel-firmware >= 2.6.32-431.el6 for package: kernel-2.6.32-431.el6.x86_64
Package kernel-firmware-2.6.32-431.el6.noarch is obsoleted by vzkernel-firmware-2.6.32-042stab083.2.noarch which is already installed
--> Finished Dependency Resolution
Error: Package: kernel-2.6.32-431.el6.x86_64 (base)
Requires: kernel-firmware >= 2.6.32-431.el6
Installed: vzkernel-firmware-2.6.32-042stab083.2.noarch (@openvz-kernel-rhel6)
kernel-firmware = 2.6.32-358.23.2.el6
Available: kernel-firmware-2.6.32-431.el6.noarch (base)
kernel-firmware = 2.6.32-431.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Answer

You cannot install a stock kernel on a OpenVZ guest. Do not attempt to do so.

Attribution
Source : Link , Question Author : Community , Answer Author : Ignacio Vazquez-Abrams

Leave a Comment